Siempre tenemos incompatibilidades y problemas con Internet Explorer, por suerte existen herramientas y arreglos para solucionar dichos problemas. :Select[ivizr] es una librería javascript que nos permitirá aplicar las pseudo-clases y atributos CSS3 a Internet Explorer (versión 6 a la 8). Es muy fácil de utilizar, únicamente tendremos que subir los archivos correspondientes a nuestro servidor y enlazarlos de esta manera:

<script type="text/javascript" src="&#91;JS library&#93;"></script>
<!--&#91;if (gte IE 6)&amp;(lte IE 8)&#93;>
  <script type="text/javascript" src="selectivizr.js"></script>
  <noscript><link rel="stylesheet" href="&#91;fallback css&#93;" /></noscript>
<!&#91;endif&#93;-->

Si IE-JS no nos convence, quizás esto sea de vuestro agrado.

Vía | Anieto2k